Can not connect to android via web server

Discussion regarding the Blue Iris Android application
Post Reply
harrydr
Posts: 1
Joined: Mon Apr 16, 2018 12:08 am

Can not connect to android via web server

Post by harrydr » Wed Jun 06, 2018 5:39 pm

Can see my cameras via lan on my computer but not via web server. can you see me tells me that it can see me. but on the setup of my webserver it can not connect and i get the time out message. if i put the in the webserver found ip than its open an huawei http://setuprouter.com/router/huawei/hg8245h/login.htm even if i not have an huawei router. Any help possible.

jiofi
Posts: 1
Joined: Mon Jul 30, 2018 7:55 am

Jiofi

Post by jiofi » Mon Jul 30, 2018 7:56 am

On 21 July 2017, Jio presented its first moderateJiofi 4G include telephone, fueled by KaiOS, named as JioPhone

User avatar
terk
Posts: 47
Joined: Tue May 22, 2018 8:30 pm

Re: Can not connect to android via web server

Post by terk » Mon Jul 30, 2018 3:08 pm

Can you see me tells you your external IP address and whether ports are open or not. However it sounds like you want to access the web interface on your cameras to set them up, is that correct? If so you want to use the internal IP address not the external so you should be looking for an IP like 192.168.1.108 for a brand new Dahua or an IP in the 10.x.x.x 172.x.x.x or 192.168.x.x ranges depending on what subnet your router is setup to use for the LAN for cameras you have already setup.

Once you get the cameras setup and working in BI and you want remote access to your BI server than you need to know the external IP or setup DDNS on your router and use that name but you should consider using that with VPN rather than opening a port for security reasons.

Mike.Bwca
Posts: 53
Joined: Sun Mar 18, 2018 10:15 am

Re: Can not connect to android via web server

Post by Mike.Bwca » Tue Jul 31, 2018 2:56 am

Please don't rage this post. I'm only trying to help those that do choose to open a port for the BI Web Server.

VPN IS the way to go.

but.......

...Many users use an open port for their BI Web Server. BECAUSE, it's simpler and easier. If you do choose to use open ports on your router to access BI remotely, you can 'limit' the ip addresses that can access your BI web server. It's a poor mans firewall, AND does not protect your network... just the BI Web Server.
1. Open BI Options.
2. Select the 'Web Server' tab.
3. Click the 'Advanced' button at the bottom right.
4. Under 'Authentication', 'Require from', select 'All Connections'.
5. In 'Limit IP addresses', you put the ip addresses that can access the BI Web Server.
  • 'Limit IP addresses' field example.....
    ------------------------------------------------------------
    -211.*.*.*,+127.0.0.1,+192.168.1.*,+123.45.678.*
For example, in the example above...
-211.*.*.* -This is an ip prefix to specifically exclude.
+127.0.0.1 - This is your local BI server loopback. Not really needed I suppose.
+192.168.1.* - This is your network.
+123.45.678.* - My phone carrier uses dynamic IP address. This is the prefix (not the real prefix). Not a perfect solution, but it still allows me to access BI using my Android BI app.m Also, it a small 255 number range. I have not had 1 instance of someone even attempting to connect from this prefix.

6. Make sure 'Log all connections, not just logins' is checked. This will let you know if anyone it attempting to connect, but cannot login because they don't have the ID and password.
7. Make sure you change the user password to something more cryptic than 'admin' or 'home', or else you will see your cameras roaming all over the place. You can also change the user names to something other than the default 'admin'.

If you do this, check the BI connections often for the first few weeks, by opening the Status page and clicking the 'Connections' tab. If you see connections, then someone has made it thru the BI port but was not able to log into your BI Web Server. If you see a Connection and/or Login... you didn't do something right in step 5. If you see login from an unknown IP address, then beware! Your BI Web Server and possibly computer has been infiltrated.

See. Simple, right! (not)

Post Reply