ChromeCast

General troubleshooting of the software
Post Reply
McTech
Posts: 6
Joined: Wed Sep 05, 2018 1:12 pm

ChromeCast

Post by McTech » Wed Apr 17, 2019 5:56 pm

Hi Guys.

I have been trying to get BI Android app working with Google Chromecast. I am really hoping someone can help me.

I have setup stunnel and this is working for remote and local connections to the cameras from within the Android app or the UI3 app. I am trying to get the cameras to show on a) Google Home Hub or B) my Google Chromecast devices.

I already have a wild card SSL certificate that is used for other services and this is from a 3rd party. Same certificate that is being used in stunnel.

I have the following in the stunnel conf

[Blue-Iris]
accept = 8443
connect = 81
cert = mctechsolutions.pem

[https]
accept = 8443
connect = 81
cert = mctechsolutions.pem

Now when i try to cast i see the Blue Iris logon on the TV screen but then it starts to flicker and then goes black and again starts to flicker. This is the same on the Google Home Hub.

I have searched the forums and followed what has been said and tried but no luck what so ever.

Now thinking our loud for a moment. My BI server is in my DMZ and lets call it Network A. My Android phone and Google Chromecast are in Network B. Network B can see and communicate with everything in Network A) Do you think this makes any difference? My cameras all work and are displayed from my S10 with no issues.

Anyway can anyone help? Thanks in advance.

Craig

Post Reply